mha startup in Mahalia

hendrikkayser
Posts: 37
Joined: Fri May 10, 2019 7:58 am

Re: mha startup in Mahalia

Post by hendrikkayser » Wed Sep 08, 2021 8:53 am

Yes, on the PHL 8, 16, 24, 32, 48, and 96kHz are supported. If the -r parameter value set in JACK does not match a supported sampling rate, the next lower one is selected, but this is not reported in the terminal output.

You can use jack_bufsize to get the actual value.

bertankursun2
Posts: 12
Joined: Tue Nov 09, 2021 4:48 am

Re: mha startup in Mahalia

Post by bertankursun2 » Wed Nov 10, 2021 3:25 am

Hi all,
I have arrived this thread after having the same errors and then I followed your path until I arrived to a point which I could not be sure how to interpret.
  • I have edited the config file so mha is not initialized at start
  • I have changed gain_live_getting_started.cfg file with new Fs 32k and moved it with
    scp phl_test.cfg mha@10.0.0.1:
  • Then below works fine

    Code: Select all

    nc 10.0.0.1 33337
    ?read:/home/mha/phl_test.cfg
    (MHA:success)
    
  • I start jack as dpoznan did only with Fs 32k:

    Code: Select all

    mha@mahalia:~$ export JACK_NO_AUDIO_RESERVATION=1
    mha@mahalia:~$ jackd -S -R -P90 -dalsa -r32000 -p64 -n2
  • Then I start MHA without any problem

    Code: Select all

    cmd = start
    (MHA:success)
    
My problem is that I don't hear anything. I am testing with headphone connected to Line Out, and BTE microphones to hdmi. Is there any setting that I should set with input/output?

Thank you very much for your support!

hendrikkayser
Posts: 37
Joined: Fri May 10, 2019 7:58 am

Re: mha startup in Mahalia

Post by hendrikkayser » Wed Nov 10, 2021 6:46 am

You may need to set up the Jack connections. Here is a list with the Jackport - device mappings:

system:capture_1 --> BTE L front
system:capture_2 --> BTE R front
system:capture_3 --> Line in L
system:capture_5 --> BTE L rear
system:capture_6 --> BTE R rear
system:capture_7 --> Line in R
system:playback_1 --> BTE speaker L
system:playback_2 --> BTE speaker R
system:playback_3 --> Line out L
system:playback_7 --> Line out R

capture_1/2 and playback_3/7 would be a good choice for you.

It may also be the case that the input/output calibration is not set up properly depending on the configuration that you have loaded and that the resulting output level is too low.

bertankursun2
Posts: 12
Joined: Tue Nov 09, 2021 4:48 am

Re: mha startup in Mahalia

Post by bertankursun2 » Thu Nov 11, 2021 3:44 am

I have changed the output channels in the .cfg file with playback_3 and playback_7 . Works fantastic!
Thanks a lot!

Post Reply