Mac: Unable to load library MHAIOJackdb

tobiasherzke
Posts: 91
Joined: Mon Jun 24, 2019 12:51 pm

Re: Error using mhactl_wrapper>mhactl_wrapper_2 (line 64)

Post by tobiasherzke » Fri Mar 04, 2022 10:21 am

Thank you for sharing the additional information, and good to see that you could overcome the problem.

To summarize:
  • openMHA's Jack modules link against the Jack library /opt/local/lib/libjack.0.dylib.
  • Jack 1.9.20 installs the Jack library as /usr/local/lib/libjack.0.dylib, however.
  • As a workaround, create a symbolic link:

Code: Select all

sudo ln -s /usr/local/lib/libjack.0.dylib /opt/local/lib/
openMHA Mac instlallers up to version 4.17.0 are affected and need this workaround.
I will see that the Mac installer of the next openMHA is not affected by this anymore (but the release date not yet planned).

tobiasherzke
Posts: 91
Joined: Mon Jun 24, 2019 12:51 pm

Mac: Unable to load library MHAIOJackdb

Post by tobiasherzke » Fri Mar 04, 2022 10:34 am

Pre-built openMHA Mac instlallers up to version 4.17.0 are affected by a changed location of the Jack library and need this workaround if users want to use openMHA with recent Jack installations:
  • openMHA's Jack modules link against the Jack library /opt/local/lib/libjack.0.dylib.
  • Jack 1.9.20 installs the Jack library as /usr/local/lib/libjack.0.dylib, however.
  • As a workaround, create a symbolic link:

Code: Select all

sudo ln -s /usr/local/lib/libjack.0.dylib /opt/local/lib/

Post Reply